Back to overview
Degraded

Degraded performance

Jun 12 at 11:50am PDT
Affected services
App

Resolved
Jun 12 at 02:08pm PDT

We are observing most GCP services recovered from the outage and our services are back to full availability. Our team is continuing to monitor.

Created
Jun 12 at 11:50am PDT

We are currently experiencing degraded performance that may be related to a Google Cloud Platform service disruption. Our team is actively investigating the issue.